Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

im trying to install a image on an cf card, last time it worked just fine. but now i only get "Retrieving Release", my shellcommand:
"sudo debootstrap --arch i386 lucid /mnt/mstr http://archive.ubuntu.com/ubuntu"
Answer is: "I: Retrieving Release" and then its stuck.

Im behind an proxy but the apt-get stuff is working fine.

now i added in the bash.bashrc: export http_proxy=http://XX.XX.XX.XX:XXXX/

in my apt.conf it was still there: Acquire::http::proxy "http://XX.XX.XX.XX:XXXX/";

With UMTS-Router its working fine, so its the Proxy i guess, any ideas to fix?

share|improve this question

3 Answers 3

I know this is old but I'll answer anyway, as I've just seen the same issue. The problem is a bug in cdebootstrap 0.55, as shipped with ubuntu lucid. See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=587526

My solution was to grab the source package for 0.57 from natty and requild for lucid. It then worked fine.

share|improve this answer

The request to retrieve the release file is hanging. That indicates a network problem; tcpdump should show you exactly where it's happening.

How are you configuring the proxy for apt-get? If you don't have http_proxy set in the environment (that's case-sensitive, by the way) then that would cause the problems you're seeing.

EDIT

Based on the tcpdump output you posted, debootstrap is attempting to contact the Ubuntu servers directly; this means that it's not using your local proxy, which brings me back to the http_proxy environment variable not being set.

share|improve this answer
    
Over the gui, but i also checked the apt.conf and its there also. the tcpdump doenst help me either. its printing something like this: 10:26:08.444677 IP UbMark.49128 > drescher.canonical.com.www: Flags [S], seq 1031662602, win 5840, options [mss 1460,sackOK,TS val 15940000 ecr 0,nop,wscale 7], length 0 if i make tcpdump host archive.ubuntu.com ! –  Mark Aug 11 '11 at 8:26
    
Add pertinent information to your question, where it can be properly formatted, rather than in a comment where it's nigh unreadable. –  womble Aug 11 '11 at 8:30
    
I updated the first post, its still not working :( –  Mark Aug 11 '11 at 8:53
    
Did you log out and back in again after modifying bashrc? Verify that it's set correctly by running echo $http_proxy to make sure it's actually set, and wget -O - http://google.com/ to make sure something can get out via the proxy. –  womble Aug 11 '11 at 8:56
    
Echo is printing the ip of the proxy and wget downloaded index.html, but still only Retrieving Release! –  Mark Aug 11 '11 at 9:33

This is old, but might help somebody with the same problem. In sudo there's usually a line

Defaults env_reset

the proxy settings will not be copied to the new root environment.

To check, type the following :

sudo env |grep http_proxy

If you don't see any output then sudo is cleaning your environment. Use visudo and add a line :

Defaults env_keep += "http_proxy https_proxy ftp_proxy no_proxy"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.