Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed Ubuntu Server here, which went fine. However, not sure what's going on here now.

I installed gnome using sudo aptitude install --without-recommends ubuntu-desktop, which worked great. But, I'm not able to use the Synaptic Package Manager!

When using the Login Screen thing I can click unlock and it asks for authorization. I enter the password I gave during install, and it works fine. But when SPM asks for my password, it doesn't accept it! What's going on? My user password is the only one I have been asked to create. I can use sudo fine in the terminal. Why does SPM block me here?

share|improve this question
2  
im not a ubuntu person myself, but try setting a root password with sudo passwd root (then give your normal password for the sudo and then a root password you want) –  Sirex Aug 11 '11 at 9:31

1 Answer 1

up vote 3 down vote accepted

If you want to set password for root, you should type command in console:

$ sudo su

(type your's user password)

# passwd

Now you can set or change password for root ;-)

share|improve this answer
    
Thanks, that fixed it :) –  Svish Aug 11 '11 at 9:54
    
A bit curious though... why wasn't this an issue with the desktop version? –  Svish Aug 11 '11 at 11:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.