Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm sure this is a dumb question, but I can't for the life of me figure out what the heck is going on. I've looked around and I've seen similar questions of this nature, but nothing exactly matching my issue.

I'm looking to replace my current file/print server. In place of the old one would be a 64 bit Windows Server 2008 R2 Standard SP1. I have added the 64 bit drivers to the server, but it's my understanding that I need to push 32 bit drivers to my clients (as they're all 32 bit machines).

So I go into the Printer Properties and select the Sharing tab. I click the "Additional Drivers" button and attempt to select x86. I then point to the 32 bit drivers for the printer in question and hit okay. Then I'm asked to provide a path to the I386 folder (which I do) but every time I click "OK"it keeps asking for that folder again. I end up in an endless loop of trying to show the system where the folder is.

Can someone provide me with some guidance about what I'm doing wrong? Any guidance is appreciated.

share|improve this question
up vote 4 down vote accepted

I had a similar question. x64 print driver keeps asking for x64 windows disk

Do what I did but from a 32-bit system.

It looks like the best way to make this work and not ask for the i386 folder is to set the printer through a x32 bit OS.

  1. Start > Run > \\servername
  2. Right click on the printer you want to add the x32 bit driver to and go to Properties
  3. Sharing tab > Additional Drivers button
  4. Check the box for x32 > Ok > Point to the location of your x32 bit drivers
share|improve this answer
This is what I'm doing but after that is when I'm asked to provide a path to the I386 folder. – DKNUCKLES Aug 11 '11 at 14:44
What file is it looking for? If you click browse, it should show the file name. I'm assuming you're missing that in your local copy of your c:\i386 – Nixphoe Aug 11 '11 at 15:07
As far as I can tell it's looking for NTPRINT.inf - when I point it to that file it keeps going in endless loops of looking for the I386 folder. – DKNUCKLES Aug 11 '11 at 15:11
Is that file in your local c:\i386 folder? It will usually look for it there first before looking for it in the cd drive. – Nixphoe Aug 11 '11 at 15:23
Ah I believe this issue has been solved. I tried this from a Windows XP machine (as opposed to my Windows 7 32 bit machine) and was able to make this happen. Thank you so much for your input! – DKNUCKLES Aug 11 '11 at 18:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.