Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When i go to http://localhost/repo/myproject/ and enter password this information is displayed:

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<D:error xmlns:D="DAV:" xmlns:m="http://apache.org/dav/xmlns" xmlns:C="svn:">
<C:error/>
<m:human-readable errcode="2">Could not open the requested SVN filesystem</m:human-readable>
</D:error>

This is my httpd-svn.conf:

<Location /repo>
      DAV svn
      SVNPath “/usr/local/repo”
  AuthType Basic

  AuthName "Subversion repository"

  AuthUserFile /etc/users

  Require valid-user

</Location>

$ ls -la
drwxr-xr-x   3 _www  wheel  102 Aug 11 22:22 repo

How can i solve this?

share|improve this question
    
Have you created an SVN repository at that location with svnadmin create, and verified that the Apache user can read from it (ie, verify that it's running as _www)? –  Shane Madden Aug 11 '11 at 21:47
    
Yes it should be correct. Apache should run over www and dir is www. when you type ls -la it's just shown as _www. I get the same error when I go to localhost/repo –  Mikael Aug 11 '11 at 22:00
    
What's your DocumentRoot set to? Also, verify that the permissions for the www user have been applied to the items within repo. Also - make sure there's no validity issues with the repo; svnlook info /usr/local/repo. –  Shane Madden Aug 11 '11 at 22:05
    
"$ svnlook info /usr/local/repo/myproject/ 2011-08-11 22:22:25 +0200 (Thu, 11 Aug 2011)" Yes everything has permisson www. What's your DocumentRoot set? - Don't know how do I check? –  Mikael Aug 11 '11 at 22:15
    
Somewhere in the Apache config - if the httpd-svn.conf file defines a VirtualHost, it should be there, otherwise check in the main httpd.conf. –  Shane Madden Aug 11 '11 at 22:18
show 3 more comments

2 Answers

up vote 1 down vote accepted

Through troubleshooting in chat, we found these error logs:

[Fri Aug 12 00:56:10 2011] [error] [client 192.168.1.2] (20014)Internal error: Can't open file '\xe2\x80\x9c/usr/local/repo\xe2\x80\x9d/format': No such file or directory 

Which led us to the quotes in the config being those sneaky, pretty “” quotes, instead of config-friendly "" quotes. That did the trick!

share|improve this answer
add comment

I had the same problem but in my case it was a file permission issue with my hook/post-commit scripts. So I changed the owner of the file and the problem was solved.

Just posting because I came to this post while trying to search for my answer since I received the exact same error message for a whole different problem and it may be useful for someone else.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.