Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a custom php.ini file which sets my session.save_path=./

With this file in place, my phpinfo() does not show PDO or PDO mysql being enabled. If I rename the php.ini file, the phpinfo() does show these as being enabled. How can I ensure they are enabled with my custom php.ini file?

share|improve this question

migrated from stackoverflow.com Aug 12 '11 at 8:31

This question came from our site for professional and enthusiast programmers.

closed as off topic by Shane Madden, MikeyB, Chris S, Chopper3 Aug 12 '11 at 18:25

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

2 Answers 2

The default php.ini on many linux distributions has a directive like include /etc/php.d/*.ini

If you want to add your own server-wide settings, add a new file with a name like zlocal.ini to that directory. Your file will be loaded last, so you can override anything you need to without losing the built in configuration or the ability to install modules using the package system.

share|improve this answer
add comment

Your custom php.ini file is almost certainly missing the PDO module. Search for extension=php_pdo.dll or something similar.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.