Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i setup apache on amazon ec2 instance with ubuntu

i using the document root set to the /mnt/www/domain.com/htdocs

i get these errors on the apache logs when any file is accessed.

[Fri Aug 12 12:26:46 2011] [error] [client xxxxxxx] File does not exist: /mnt
[Fri Aug 12 12:26:46 2011] [error] [client xxxxxxx] File does not exist: /mnt
[Fri Aug 12 12:26:47 2011] [error] [client xxxxxxx] File does not exist: /mnt

fstab file:
/dev/xvda2      /mnt    auto    defaults,nobootwait,comment=cloudconfig 0       2
/dev/xvda3      none    swap    sw,comment=cloudconfig  0       0


<VirtualHost *:80>
        ServerAdmin webmaster@domain.com
        ServerName  www.domain.com
        ServerAlias domain.com

        # Indexes + Directory Root.
        DirectoryIndex index.php
        DocumentRoot /mnt/www/www.domain.com/htdocs/

        # CGI Directory
        ScriptAlias /cgi-bin/ /mnt/www/www.domain.com/cgi-bin/
        <Location /cgi-bin>
                Options +ExecCGI
        </Location>


        # Logfiles
        ErrorLog  /mnt/www/www.domain.com/logs/error.log
        CustomLog /mnt/www/www.domain.com/logs/access.log combined
</VirtualHost>

what could be the issue?

After further research

I fixed it myself, i had earlier enabled chroot module in apache config and after diabling it worked..

share|improve this question
    
Does /mnt actually exist? And have you checked permissions if it does? –  Bart Silverstrim Aug 12 '11 at 12:33
    
it exists.. drwxr-xr-x 3 root root 4.0K 2011-08-12 12:18 mnt –  krisdigitx Aug 12 '11 at 12:34
    
Please post your Apache configuration file? –  quanta Aug 12 '11 at 12:45
add comment

1 Answer

up vote 0 down vote accepted

Based on your update, you might want to reenable chroot and update the VirtualHost entries so that they refer to the directory structure of the chroot environment.

share|improve this answer
    
cool will try... –  krisdigitx Aug 13 '11 at 15:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.