Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to debug an exim configuration issue (Ubuntu) and I see lots of lines in the config such as:

remote_smtp:
   debug_print = "T: remote_smtp for $local_part@$domain"
   driver = smtp

However, I cannot figure out how to get the output of these statements. I've tried editing /etc/default/exim4 and adding various CLI parameters there such as -v, -d, -d+all and while they do have an effect, the debug_print lines are nowhere to be found (stderr,stdout,/var/log/exim4/mainlog).

How do enable and where do I then find the "T: remote_smtp for ..." output?

share|improve this question
    
Were you able to figure this out, I'm in the same situation. – Daniel Sokolowski Feb 14 at 5:14
    
Well it's been a long time but IIRC the accepted answer was sufficient for me to get what I needed. – ColinM Feb 15 at 17:30
up vote 1 down vote accepted

According to the exim docs

If this option is set and debugging is enabled (see `-d', `-v', and `debug_level'), 
then the string is expanded and included in the debugging output when the transport
is run.

You can verify this is working by running exim manually on the command line:

exim -d+all -bP transport remote_smtp

Did you try adding debug_level 1 to your exim config?

share|improve this answer

I, as well was not able to see any additional info by modifying /etc/default/exim4, and adding debug_level 1 in my configuration file was erroring out.

What worked for me was running exim4 in foreground using the same command line parameters that Debian/Ubuntu starts it with and adding d+all to it:

root@sh1:/srv/www/static# ps -A | grep exim
12886 ?        00:00:00 exim4
root@sh1:/srv/www/static# cat /proc/12886/cmdline
/usr/sbin/exim4-bd-q30m
root@sh1:/srv/www/static# service exim4 stop

Now start exim in foreground, note you have to add spaces between the parameters:

root@sh1:/srv/www/static# /usr/sbin/exim4 -bd -d+all -q30m
22:19:03 12969 Exim version 4.84 uid=0 gid=0 pid=12969 D=fffdffff
Berkeley DB: Berkeley DB 5.3.28: (September  9, 2013)
Support for: crypteq iconv() IPv6 PAM Perl Expand_dlfunc GnuTLS move_frozen_messages Content_Scanning DKIM Old_Demime PRDR OCSP
...
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.