Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm developing a service which requires me to generate a new email for every "sign up." For example, person000@name.com, person001@name.com, person002@name.com, and so forth. My first attempt was creating a gmail account and doing a person+000@gmail.com thing, but when I send the email and make the "From" address to "person+000@gmail.com" the google email server changes it to without the +000.
Oh and when someone emails any of the email addresses, they all go to the same email account (ie person@name.com). If anyone knows of an email server for FreeBSD that can do this, please let me know!

share|improve this question
    
It's quite unclear what the problem is that you're trying to solve. Are you trying to allow sending via an arbitrary email address through a gmail server? –  MikeyB Aug 15 '11 at 5:32
    
this is what i want to do: i want to send an email from an account person@name.com with an alias of person001@name.com (personXXX@name.com), and when the recipient responds to "person001@name.com" it goes to the person@name.com account. idc how i achieve this :P –  Mike S. Aug 15 '11 at 5:41
    
How are you sending the messages? I highly doubt Google would actually change the 'from' on an incoming message. Are you sure you are setting both from fields? –  Zoredache Aug 15 '11 at 6:58
    
@Zored: his problem is when he sends the email through Google, they change the From address to what his account is allowed to use. Google does this to prevent spoofing. –  MikeyB Aug 15 '11 at 14:22

1 Answer 1

up vote 2 down vote accepted

You've got the right idea. Use the email+localpart@domain.com as the From address, just don't send it through Google. This is the simplest way and requires no further configuration. Sendmail (and others) support this out of the box.

Google requires that you verify each email address that you want to send From, to prevent spoofing. This is why it's changing your From address.

share|improve this answer
    
sweet thanks! didn't know the +local was widely supported. –  Mike S. Aug 15 '11 at 15:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.