Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Just installed Debian 6 box. I wanted to mount my S3 bucket for some backups. So I followed instructions for http://code.google.com/p/s3fs/ .

1) I installed all perquisites asked in installation instruction. 2) Compiled and installed s3fs. 3) Configured by putting my credentials to passwd-s3fs. 4) Tried to mount my bucket: "/usr/bin/s3fs backupejekabsons /mnt"

I get error message "fuse: failed to open /dev/fuse: Permission denied" After googling a bit, I found out that I need to add "fuse" group to my account.

I added a group and relogged. Didn't help. I tried to reboot VM, still no result.

Some output that may be helpful: 1) edgarsj@1310-700-4568:~$ groups fuse edgarsj rvm

2) edgarsj@1310-700-4568:~$ id uid=1001(edgarsj) gid=111(fuse) groups=1002(edgarsj),111(fuse),1000(rvm)

3) edgarsj@1310-700-4568:~$ ls -la /dev/fuse crw-rw---- 1 root fuse 10, 229 Aug 12 15:36 /dev/fuse

I also tried to add this group to root and run as sudo. Same result.

Thanks for your attention, mates. Any help is appreciated.

share|improve this question

migrated from stackoverflow.com Aug 15 '11 at 12:45

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer

up vote 0 down vote accepted

Does this discussion help? http://groups.google.com/group/s3ql/msg/8cf247561362f378

Basically, the VM host may not be actually giving you permission to use /dev/fuse.

They've added to solution to the s3ql FAQ: http://code.google.com/p/s3ql/wiki/FAQ

share|improve this answer
    
Thanks for your answer. Posted a ticket to my VPS provider. I hope they will grant access. –  Edgars Jekabsons Aug 16 '11 at 10:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.