Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've successfully got php 5.3 working on centos and now I need to update my phpmyadmin as its throwing errors. I first tried to remove the current one using yum:

yum remove phpmyadmin

which appeared to work, but http//ip.address/phpmyadmin still worked! So I then removed the phpmyadmin config file from:

/etc/httpd/conf.d/phpMyAdmin.conf

and it didn't work.

I've created a folder phpmyadmin in my domain root and put a test file <?php phpinfo(); ?> but when i go to mydomain.com/phpmyadmin it is bringing to the outdated phpmyadmin install, even though the conf is deleted from httpd/conf.d!

I'm running out of ideas, if anybody could help me - the end game is to have an updated version of phpmyadmin, which is not in the centos repositories.

thanks for your help ;)

share|improve this question
    
Have you also restarted the webserver before trying the new configuration? (I think it's service httpd restart on RedHat-based systems). –  O G Aug 16 '11 at 16:45
    
yep i did. The funny thing is that before I restarted going to domain.com/phpmyadmin gave a 404 not found as expected. After the httpd restart domain.com/phpmyadmin showed the old instalation! –  Coombesy Aug 16 '11 at 16:47
    
And a grep -ril phpmyadmin /etc/httpd (or /etc/apache|/etc/apache2, whichever your apache folder is) - what would this return? –  O G Aug 16 '11 at 16:50
    
# grep -ril phpmyadmin /etc/httpd/ /etc/httpd/logs/error_log.2 /etc/httpd/logs/error_log.1 /etc/httpd/logs/access_log.2 /etc/httpd/logs/access_log.4 /etc/httpd/logs/access_log.1 /etc/httpd/logs/error_log.4 /etc/httpd/logs/error_log.3 /etc/httpd/logs/access_log /etc/httpd/logs/error_log /etc/httpd/logs/access_log.3 grep: /etc/httpd/run/saslauthd/mux: No such device or address grep: /etc/httpd/run/pcscd.comm: No such device or address –  Coombesy Aug 16 '11 at 16:58
    
It is a bit strange - unless you still have a directory named phpmyadmin in your default virtualhost DocumentRoot (usually /var/www) which would contain a phpmyadmin instance that was not installed via distro's package management system. Can you also verify this part? –  O G Aug 16 '11 at 17:02
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.