Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have problem to install mysql-server on Ubuntu.

I typed in command-line:

sudo apt-get install mysql-server-5.1

Then I got this:

sale@sale-desktop:/var/www$ sudo apt-get install mysql-server-5.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libhtml-template-perl mysql-server-core-5.1
Suggested packages:
  libipc-sharedcache-perl tinyca
The following NEW packages will be installed:
  libhtml-template-perl mysql-server-5.1 mysql-server-core-5.1
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/11.8MB of archives.
After this operation, 27.1MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
Selecting previously deselected package mysql-server-core-5.1.
(Reading database ... 314812 files and directories currently installed.)
Unpacking mysql-server-core-5.1 (from .../mysql-server-core-5.1_5.1.41-3ubuntu12.10_i386.deb)  ...
Selecting previously deselected package mysql-server-5.1.
Unpacking mysql-server-5.1 (from .../mysql-server-5.1_5.1.41-3ubuntu12.10_i386.deb) ...
Selecting previously deselected package libhtml-template-perl.
Unpacking libhtml-template-perl (from .../libhtml-template-perl_2.9-1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up mysql-server-core-5.1 (5.1.41-3ubuntu12.10) ...
Setting up mysql-server-5.1 (5.1.41-3ubuntu12.10) ...

Installation stops here and I am waiting and just NOTHING, I had to stop installation with ctrl+z and post problem :)

share|improve this question
1  
Waiting is the trick. Or seeing the last entries in /var/log/syslog. –  mailq Aug 17 '11 at 16:14
    
It isn't tiny. Internet access hiccup? –  Paul Aug 19 '11 at 1:42
    
No it wasn't. I can't remember how I solved this but I think that I reinstall something .... –  tasmaniski Feb 23 '12 at 11:32
add comment

1 Answer

First thing is... you should use MySQL 5.5 (latest and greatest) if at all possible.

Second thing is... you should just download the package from MySQL's website and install it locally, instead of using apt-get. Use package manager to install it once you have it downloaded.

Link to MySQL 5.5 downloads...
http://dev.mysql.com/downloads/mysql/5.5.html#downloads
Select "Debian Linux" from the drop-down menu.

Link to MySQL 5.1 downloads (not recommended)...
http://dev.mysql.com/downloads/mysql/5.1.html#downloads
Select "Linux - Generic" from the drop-down menu.

Without more info my "gut" tells me it's a compatibility issue because you're asking specifically for 5.1... but I don't know what version of Ubuntu you're trying to install that on so it could be perfectly fine.

Try...

sudo apt-get install mysql-server

...without the version and see what package it gives you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.