Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

On my Mac OSX Apache server there are 2 sites, school and club, with web roots at www/school and www/club. Apache is configured via virtual hosts to serve school at and club at The most salient difference between the two sites is that club uses a Drupal installation whereas school is written in a custom Coldfusion framework.

This configuration worked quite nicely until recently, when it seems that the Drupal installation in www/club suddenly began treating as a node somehow, trying to load the club site's template css and modules when the school site's index is accessed, resulting in very messy page. Other pages in www/school are unaffected, only the index page seems to have been eaten by Drupal.

I don't have much Drupal experience, and I am utterly baffled how the Drupal installation in one site of a virtual host setup can hijack the other site. Does anyone have any idea what I should change to tell Drupal to stay in its own site?

share|improve this question

migrated from Aug 17 '11 at 19:55

This question came from our site for Drupal developers and administrators.

This more specific to Drupal than being a webmaster and since no one has answered on webmasters, I am going to migrate it to the drupal site. – RandomBen Aug 12 '11 at 11:34
What makes you think the Drupal club site is involved? – Keith Morgan Aug 12 '11 at 13:46
Have you specified the base URL in the Drupal install's settings.php? (line 145 in D6). At the top of settings.php is a guide to naming conventions, in case you need to specify a non-default 'sites' folder. – akalata Aug 16 '11 at 1:44
Drupal on its own has no mechanisms to hijack control outside of its directory. This is most likely an apache configuration issue, in the virtualhost configuration or a .htaccess file in the directory for – freiheit Aug 17 '11 at 18:28
Can you also post the VirtualHost declarations? – alanthing Oct 14 '11 at 11:17

1 Answer 1

Without knowing if you're on shared hosting or not; it smells like the NameVirtualHost might be missing. This would means that your secondary host is routing to the wrong VirtualHost (because you haven't got vhosting configured correctly).

Have a look for something like:

NameVirtualHost *:80
# or
NameVirtualHost *:443
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.