Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Samba server acting as a PDC. All of my users can login locally to any machine on the network with their Samba userID.

The problem is, when a user tries to use remote desktop to access a machine with their Samba userID, they get a "system policy does not allow you to login interactively" message.

I can fix this problem on a per-user basis by adding all of the users to the remote users list on each machine, but that would take forever. How do I tell the Windows XP machine to allow remote desktop access to any user with valid domain/samba account?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Instead of adding a user in the remote users list, add the 'Domain Users' group or some other group.

Create a script that adds a domain group the Remote Desktop Users group on the xp machines.

The exact details will depend on how you push settings to all the machines, on your domain.

share|improve this answer
1  
In a typical Active Directory domain you would push these settings via group policy. Not sure if Samba has that capability though. –  Kevin Colby Aug 17 '11 at 21:00
    
This isn't working... In "System Properties" -> "Remote" -> "Select Remote Users", I choose "Add", Select "Locations", choose my domain, Select "Object Types", and choose "Groups", enter the group name "Employees" (which all domain users are a member of on the Linux machine), and choose "check names". It accepts "MYDOMAIN\Employees" as valid. I click OK, and then it shows "MYDOMAIN\MyUserName" in the list of valid users. It's changing the group to just my user name when I choose OK. Am I doing this wrong? –  Nick Aug 18 '11 at 14:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.