Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Our website uses the wordpress contact forms 7 plugin to send emails. These are for people who want us to contact them.

This just uses the default MTA on our server which is exim.

Everything worked great and then we migrated our mail servers to exchange on a different server.

Our MX record is pointing to the new server and incoming and outgoing email works great.
But the contact forms on the website still send the emails to the localhost.

Which makes sense. That is what it did in the past. But I need to change it so users still get their emails.

How do I change exim to not accept mail locally but just relay it on to the mx record for the domain?

I tried adding the text at Exim: how to deliver locally and send a copy to another server but it gives me an error

Exim configuration error in line 1343 of /etc/exim.conf missing error type.

do I need to put the text

smarthost:
            driver = manualroute
            domains = currentdomain.com
            transport = remote_smtp
            route_data = "mxrecordofdomain"

at a certain place in the file.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Exim is delivering locally because the destination domain matches one that you've configured Exim to consider local. Smarthosting doesn't come into it, because that only kicks in once Exim's decided to route the e-mail somewhere else, and that's not what's happening.

The easiest way to handle this just to grep through your Exim config for your domain, and remove them. I can't remember the exact name of the option(s) involved; I got rid of my last Exim server in favour of Postfix some years ago.

share|improve this answer
    
This worked. I commented out the line I added the line domainlist local_domains = The mail now comes to our new mail server! Thanks for the help! –  ChickenFur Aug 18 '11 at 17:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.