Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When i run

cat /proc/partitions

I get ( notice the block size of sd4 )

major minor  #blocks  name

   8     0 1169686528 sda
   8     1     104391 sda1
   8     2    2096482 sda2
   8     3    2096482 sda3
   8     4          1 sda4
   8     5 1165387198 sda5

but if I run

/sbin/fdisk -l /dev/sda

I get again ( notice sda4 )

Disk /dev/sda: 1197.7 GB, 1197759004672 bytes
255 heads, 63 sectors/track, 145619 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14         274     2096482+  83  Linux
/dev/sda3             275         535     2096482+  82  Linux swap / Solaris
/dev/sda4             536      145619  1165387230    5  Extended
/dev/sda5             536      145619  1165387198+  83  Linux

This may have something to do with the servers raid configuration as the sda4 is not even mounted or in fstab.

Is this normal?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

/dev/sda4 is showing as having no useful size because it is, in effect, "not a partition". It's an "extended" partition, that is, a container for other partitions. In short, it is a strange and annoying artifact of the limitations of the DOS format partition table. You can ignore it for the purposes of answering the question "what partitions do I have?"

For a ridiculous amount of information on the format and it's history, consult Wikipedia.

share|improve this answer
    
Thanks a lot, I suspected as much but had to be sure. –  Mon Villalon Aug 18 '11 at 4:30

look at the start and end cylinders on sda4 and sda5, i think something happened with fdisk and sda5 has overwritten sda4.

Try partitioning sda4 and sda5 again

share|improve this answer
    
Good ghods no. Don't format /dev/sda4. –  womble Aug 18 '11 at 4:23
    
Yeah I noticed that too after asking the question, But then I noticed the extended , could it mean that the extended partition doesn't consume any blocks? –  Mon Villalon Aug 18 '11 at 4:25
    
sorry i meant partition. i must admit i did wonder if the extended tag caused this but i couldn't find any info on it. –  Silverfire Aug 18 '11 at 4:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.