Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Juniper SSG 5 running Screen OS 6.2.0r9.0 at appears to be dropping packets. When downloading files (in a browser or FTP client like filezilla) sometimes they will just “hang” half way through, and the only way to fix it is to pause and resume the download. When I tried to our external IP from inside our network I found that I was getting some packet loss. I telented into the SSG and ran:

ssg5-serial-> ping
Target IPv4 address:OurExternalIP
Repeat count [5]:10000
Datagram size [100]:
Timeout in seconds[1]:
Source interface:bgroup0
Type escape sequence to abort
Sending 10000, 100-byte ICMP Echos to OurExternalIP, timeout is 1 seconds from bgroup0
!!!!!!!!!!!

< snip>

!!!!!!!!!!
Success Rate is 99 percent (9993/10000), round-trip time min/avg/max=2/3/214 ms

(external IP is in Untrust and bgroup0 is in Trust) I thought this might be an issue with load or a hardware thing. I grabbed our cold spare and tried the same thing in a test environment with no load on the SSG, the same thing happened. I did a factory reset and just setup the addresses on each interface and ran the same again with no policies or settings and still lost ~10 packets. Can the SSG5 just not handle the load from Trust to Untrust and back? Or is it throttling not just my icmp requests, but on the production one http and ftp downloads? All my previous experience has been with Cisco kit so any advice would be greatly appreciated. I did find this Light packet loss through router but it dosnt quite answer my question.

share|improve this question
    
You might include your LAN configuration, if one is in use during/for your testing - what is between your test system and the Juniper? –  user48838 Aug 18 '11 at 8:53
    
Hi, Thanks for the comments, there was no LAN in use when testing, it went: My PC(Static:10.1.1.2)-1M Cat6 Patch Lead-->SSG5(Bgroup0:10.1.1.1, eth0/0:external IP) I also had a pc (Paused at BIOS) pluged into eth0/0 so it would be up and I could ping it. –  Hybrid Aug 19 '11 at 0:42
    
"Success Rate is 99 percent (9993/10000)...~10 packets" Have you looked at the MTU of the test/testing system(s)? –  user48838 Aug 19 '11 at 9:22
    
Did you ever get anywhere with this? We've got similar symptoms –  Rob Nicholson May 23 '13 at 21:53
    
We found that the downloads freezing was fixed when we got more bandwidth although not the packet loss. We went from 2/2Mbps to 10/10Mbps and the issues disappeared. I still suspect the SSG5 of doing something funky because downloads should just have been slower but not stalled (I guess it also could have been our ISP but I don’t think so) but never looked into it any further, sorry. –  Hybrid May 27 '13 at 5:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.