Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install XCache on Windows. I'm running Xampp 1.7.5 beta, with php 5.3.6 (ts, vc9). I've got the relevant XCache dll in php/ext.

I would expect to then write the following line in php.ini:

zend_extension_ts = D:\xampp\php\ext\php_xcache.dll

However, that does nothing.

If I write:

zend_extension = D:\xampp\php\ext\php_xcache.dll

then doing php -v gives me the correct expected output:

PHP 5.3.6 (cli) (built: Mar 17 2011 10:37:07)
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
    with XCache v1.3.2, Copyright (c) 2005-2011, by mOo
    with Xdebug v2.1.1, Copyright (c) 2002-2011, by Derick Rethans

HOWEVER, this causes any php call APART from getting the version to die silently (even with display_startup_errors on). So, if I now do echo "<?php phpinfo(); ?>" | php, I get nothing. Uncommenting the zend_extension in the ini file makes everything run correctly again.

Any ideas?

share|improve this question
    
Might I suggest that you check the web servers log, or enabling debugging on the web server, since it might be a problem relating to your web server, rather than PHP itself. –  Mike Aug 18 '11 at 9:25
    
The same thing happens even from the command line, though -- enable xcache and then run php somefile.php from the command line and it just dies, no matter what's in somefile.php -- however, running php -v works as above. –  Jeremy Warne Aug 28 '11 at 3:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.