Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On the dialog "object types" I see:

  • Built-in security principals

  • Users

  • Groups

But "Computers" is not there. How can I grant permissions for a computer user?

share|improve this question
    
can you post a screenshot? Perhaps you're looking at the wrong object types dialogue. –  Mark Henderson Aug 18 '11 at 23:32
    
@Mark Henderson: This question is related to another question I did. Please check the screenshoot of the accepted answer. serverfault.com/questions/302223/… –  Timmy O' Tool Aug 18 '11 at 23:37
    
I'm trying to change permissions for a folder –  Timmy O' Tool Aug 18 '11 at 23:37
    
gotcha. That's the correct place to be looking. –  Mark Henderson Aug 18 '11 at 23:48
    
Is this server on a domain? –  Mark Henderson Aug 18 '11 at 23:48
show 2 more comments

2 Answers

up vote 6 down vote accepted

I'm doubtful that the server in question is joined to a domain for the reason that there are no "local" computer accounts, there are only "domain" computer accounts and that accounts for why the computer object type is not present. Can you verify that the server is in fact joined to a Windows domain? If so, what type of domain? Windows NT, 2000, 2003, or 2008?

Can you give us a screenshot verifying the domain membership of this particular server?

share|improve this answer
    
maybe I'm confused. How can I check if the computer is joined to a domain? In case it's not joined is not possible to add computers accounts? –  Timmy O' Tool Aug 19 '11 at 1:20
    
1. Bring up the System Properties, select the Computer Name tab, look at what is reads for Full computer name and either Workgroup or Domain. You might try posting a screen shot of that tab for us. 2. There are no "local" computer accounts so if the computer is not joined to a domain then you won't be able to grant permissions on the folders to any computer accounts, because they don't exist. –  joeqwerty Aug 19 '11 at 1:36
    
My fault, the computer is joined to a Workgroup but not to a domain. Then, computer accounts are not available :( –  Timmy O' Tool Aug 19 '11 at 1:54
    
Glad you got it figured out. On a side note, computers aren't actually "joined" to a Workgroup. A workgroup is a loose "association" of computers in the sense that they appear together in Network Neighborhood (or My Network Places) but they share no central user database, authentication provider, etc. –  joeqwerty Aug 19 '11 at 1:58
    
thanks for your help!. Then, granting remote permissions to Network Service is out of my possibilities, right? Please see my previous question serverfault.com/questions/302223/… –  Timmy O' Tool Aug 19 '11 at 2:04
show 3 more comments

I see Built-in security principals, Service Accounts, Computers, Groups, Users.

Not that I have much clue what kind of object you are setting the security for, or on what OS.

I guess whatever item you are setting security on cannot have computer account security set on it?

EDIT

What happens if you do it from the command line? e.g.

cacls "c:\folder\wherever" /E /G "domainname\computername$:F"
share|improve this answer
    
Setting permissions for a folder, the OS is on the question tags... –  Timmy O' Tool Aug 18 '11 at 23:35
    
Ah, and, so it is. –  TessellatingHeckler Aug 19 '11 at 0:02
    
See edit for suggestion. –  TessellatingHeckler Aug 19 '11 at 0:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.