Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a server running Windows Server 2008. It runs DC, DNS etc and has RRAS configured. Users can VPN OK, with no issues. Under normal operation server can be found at .3, however once a VPN user connects, a new DNS record is created, .90, and any attempts to access the server via path name (\server) are reouted to .90 instead of .3. As .90 isn't the server but the VPN, users mapped drives no longer work. Deleting the DNS entry at .90 solves the problem again until the next time the VPN is logged in, in which case the DNS record is recreated and all the problems occur again.

To solve this, we have moved the RRAS to another server running 2003. This does not create a new DNS record. As far as I can tell, this is a Server 2003 v 2008 difference, and 2003 does not put a new record into the DNS.

Can anyone shed any light on this? Why does 2008 add a DNS record and 2003 does not? Is there a way to disabled 2008 putting another record in the DNS and thus prevent breaking the internal network?

Thanks, Andy

share|improve this question

1 Answer 1

up vote 1 down vote accepted

See if this works.

  1. Start DNS Manager.
  2. Right-click the DNS server at the top of your tree on the left > click Properties.
  3. You should be on the Interfaces tab
  4. Click Only the following IP addresses.
  5. Remove any Routing and Remote Access IP addresses that are listed.
share|improve this answer
    
That setting determines which ip addresses the DNS server listens on but it sounds to me like the problem is that the server is registering it's RRAS connection in DNS. –  joeqwerty Aug 19 '11 at 15:10
    
@joeqwerty I agree with your assessment, I was hoping that wasn't just the listening connection. –  Nixphoe Aug 19 '11 at 15:15
    
Sorry - forgot this was open. Anyway, turned out that there was a number of connections set up, including one for a company that connected on the floor below. This was no longer needed so removed and fixed :) –  Naozumi Nov 2 '11 at 15:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.