Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a script that updates me on any changes to the kernel log on my (Debian) servers.

The problem is that occasionally the log contains lines like:

last message repeated 4 times

I realize that this is a feature to shorten the size of the logs - but would prefer in this case that every instance of the message be logged instead.

Is there a way to turn off this feature?

share|improve this question
    
You should really reconsider :) I have previously had log messages repeating several thousand times per second and you really don't want these writes happening. –  Antoine Benkemoun Jun 30 '09 at 18:24

4 Answers 4

up vote 3 down vote accepted

On BSD systems, syslogd has -c option, you could start syslogd -cc to disable this feature.

On linux (checked on Debian), man syslogd lists no such option.

It would seem that there is no way to turn it off under linux:

http://www.syslog.org/forum/syslog-and-syslogd/disable-'last-message-repeated'-compression-on-lin/

share|improve this answer

Control repeat message filtering using $RepeatedMsgReduction in /etc/rsyslog.conf (it's on by default on Ubuntu systems):

# Filter duplicated messages
$RepeatedMsgReduction on

More details: http://www.rsyslog.com/doc/rsconf1_repeatedmsgreduction.html

share|improve this answer

On RedHat-family distros, or distros using rsyslogd, you add -e to SYSLOGD_OPTIONS in /etc/sysconfig/rsyslog.

Then restart the rsyslog service.

share|improve this answer

On Ubuntu, you can add -e to RSYSLOGD_OPTIONS in /etc/default/rsyslog and "restart rsyslog". It's not documented in the man page, but it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.