Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are supporting a client with primarily Windows XP machines. The users need to use Remote Desktop to connect to a terminal server. Unfortunately, after upgrading to SP3 on some machines MSTSC.exe crashes when they try to connect to the terminal server (a Win 2008 machine). The resolution I have found has been to revert to an older version of MSTSC as described here: . Another tech at my company independently arrived at a similar solution.

Unfortunately, now some of the user's printers are missing (when connected tot he terminal server). Has anyone else seen this issue? How did you resolve it?

share|improve this question
Rotard- Can you post the event log that corresponds with the crash? That will help pinpoint which module is faulting. Are you using a program called triCerat Screwdrivers by any chance? – Sean Earp Jun 24 '09 at 23:43

i had similar problem, try this:

  1. remove content of C:\Documents and Settings\user\Local Settings\Application Data\Microsoft\Terminal Server Client\Cache
  2. log off, log on

don't ask why... it just did the trick for me.

share|improve this answer
Many thanks! This solved my seperate issue. Windows 7 client would RDP to non-NLA machines, but NLA machines would crash with "remote desktop connection has stopped working". Faulting module would be facredprov2.dll. Clearing this cache worked a treat. – justinsteven Jul 11 '11 at 4:05
You should get additional + for the "don't ask why" bit :) – Zlatko Mar 28 '13 at 14:48

I know this really doesn't solve the problem, but more works around it, but you may want to see this serverfault post.

The only other thing I would do is rollback from SP3, I have heard other (all-be-it antidotal), stories of people not liking SP3 for various reasons. This however may not be an option.

share|improve this answer

I found another answer to this! If you are trying to connect to any computer using Windows XP Remote Desktop and keep getting a crash error after clicking 'connect' this is the solution.

Run CCleaner! Or run Disk Cleanup...

I spent about 2 hours on this issue, and after running CCleaner and disk cleanup I had NO ISSUES!! sorry to bring this thread back to life but this is the number 3 solution on google...

share|improve this answer

I have this same problem, however, I was able to pinpoint the cause. It only happens if I log in to the remote computer with a thin client, then a thick client and back to the thin client. I believe the problem is with the thin client somehow but I can't find any logs that indicate what happened during this crash. My thin client is an HP t5710 running XPe.

share|improve this answer

The issue has not come up again to my knowledge, but I think the problem may actually be a symptom of a greater problem: every (all of 2-3) machine that has exhibited this behavior has required a reformat in approximately a month or so of the time the mstsc problem surfaced. So I think the standard procedure, if it comes up again, will be to just reformat

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.