Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running subversion 1.4 on Centos 5.2 and my clients are using tortoise to do their check out, commit etc. I think I have permissions problems but I have configured the folder to accessible to everyone with 777 attribute but I seem not to be getting anywhere. Its generating this error on tortoise "svn: Can't open file 'PATH/TO/MY/FILES/entries': Permission denied". Some guy was suggesting some indexing software installed on the client machine like google desktop, any suggestions?

share|improve this question
1  
Is Subversion running through Apache or svnserve? –  BonkaBonka Jun 23 '09 at 14:40
    
svnserve, thanks –  Rungano Jun 25 '09 at 9:30
add comment

2 Answers 2

One thing note, If a parent folder does not grant traverse permission (the execute flag x), then non-root users will get an error message, even if the leaf directory node is set to 777. Also, if you are using Apache, you will need to make sure that there is config block that allows access to your files.

share|improve this answer
add comment
up vote 2 down vote accepted

The solution is with samba, after a long grill with permissions we discovered that for some reason you need to add these entries in the smb.conf file.

force create mode = 0774 delete readonly = yes

I know to some of you it might sound crazy considering that you have the write permission enable already, it think its a bug!!LoL :)

share|improve this answer
    
First of all, I want to hug Rungano for pointing me in the right direction. His answer also takes care of a simular problem: If you are developing on a local development server and use samba mounts to reach your working copy, you can get in trouble with files inside the .svn folder getting permissions that are too restrictive. This will wreck merge, update and commit operations. The same solution applies. Again, thanks a million Rungano. –  Douwe Feb 17 '11 at 15:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.