Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I followed this tutorial: http://docs.cpanel.net/twiki/bin/view/AllDocumentation/WHMDocs/EximDifferentIps

To specify "which IP addresses specific domains on your server should send mail with Exim".

I restarted exim. I restarted the server. No matter what I do, all of the emails that are supposed to be coming from MYDOMAIN.COM (ip 1.2.3.4) are coming from MY.SERVER.HOSTNAME.COM (ip 5.6.7.8).

I have setup rDNS and PTR records so I would very much like my emails to be coming from the ip address and domain name they are supposed to be coming from.

share|improve this question
    
Apparently I was doing it backwards, and if you have a dedicated IP for each domain then you can enable "Send mail from account’s dedicated IP" in Main >> Service Configuration >> Exim Configuration Editor >> Domains and IPs and leave those 2 files mentioned in the URL alone, then it will ALMOST work. I have done that, but there are still traces of default@hotname.serverhostname.com in my email headers :S –  darkAsPitch Aug 23 '11 at 3:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.