Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to configure an ubuntu vps. I have set up ssh secure login using rsa public and private keys from a local machine.

As well as disabling root login I have also set up iptables and configured to allow ports 80 and 22 (port 22 only from my ip address) for the ssh tunnel.

I can connect fine using ssh but when I try using scp from my local machine

sudo scp /var/www/filetocopy user@remoteaddress:/var/www/filetocopy

I get this error

Permission denied (publickey).

I have added the -v to display the output

Executing: program /usr/bin/ssh host ip.add.re.ss, user username, command scp -v -t -- /var/www/filetocopy
OpenSSH_5.8p1 Debian-1ubuntu3, OpenSSL 0.9.8o 01 Jun 2010
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to ip.add.re.ss [ip.add.re.ss] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_rsa-cert type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: identity file /root/.ssh/id_dsa-cert type -1
debug1: identity file /root/.ssh/id_ecdsa type -1
debug1: identity file /root/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.5p1 Debian-4ubuntu4
debug1: match: OpenSSH_5.5p1 Debian-4ubuntu4 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.8p1 Debian-1ubuntu3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA b5:ea:fe:e6:07:a9:a6:3e:d2:6f:2d:3f:86:55:04:5f
debug1: Host 'ip.add.re.ss' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:2
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/id_rsa
debug1: Trying private key: /root/.ssh/id_dsa
debug1: Trying private key: /root/.ssh/id_ecdsa
debug1: No more authentication methods to try.
Permission denied (publickey).
lost connection

Thanks again for the help so far

share|improve this question
1  
Have you disabled password authentication ? The local user you are using when running sudo, is root. Therefore, if you uploaded your user's private key (instead of root's) the key won't match. –  Torian Aug 22 '11 at 17:18
add comment

1 Answer

up vote 0 down vote accepted

The only way I can get the same result as you is if I remove the the authorized_keys from the remote host. Check that the public key in user@remoteaddress:~/.ssh/authorized_keys matches the identity file for the user on the local machine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.