Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to share a directory on a centos box. I tested out configuring it on my ubuntu desktop before trying it on the centos machine and every thing worked fine. The smb.conf is setup the same and I have done smbpasswd as well as added the user to /etc/samba/smbusers. When I try to mount the share I get the message "Unable to find suitable address".

I thought it might be that because the samba server is Centos 6 it might be an SELinux issue. So after a little google I found this: http://aaronwalrath.wordpress.com/2011/03/26/install-samba-server-on-red-hat-enterprise-linux-6scientific-linux-6/ After doing the things mentioned there I still get the same Unable to find suitable address message.

In /var/log/samba/log.smb I have this output.

[2011/08/22 11:07:42.198369,  0] printing/print_cups.c:108(cups_connect)
  Unable to connect to CUPS server localhost:631 - Connection refused
[2011/08/22 11:07:42.202031,  0] printing/print_cups.c:108(cups_connect)
  Unable to connect to CUPS server localhost:631 - Connection refused
[2011/08/22 11:07:43.224267,  0] smbd/server.c:500(smbd_open_one_socket)
  smbd_open_once_socket: open_socket_in: Address already in use
[2011/08/22 11:07:43.224689,  0] smbd/server.c:500(smbd_open_one_socket)
  smbd_open_once_socket: open_socket_in: Address already in use

I read that this is a bug and that output does not mean that samba wont work from here: https://bugzilla.redhat.com/show_bug.cgi?id=726936

What could cause this? Is there anything special that needs to be configured in Centos 6 vs Centos 5 for samba? I am pretty sure most of the info I see on line about Centos and samba is from before the time that Centos 6 was released.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Turns out that Centos 6 had iptables running by default and it was blocking communication on that port. I hope this helps any one else who runs into this sort of thing in the future.

share|improve this answer

I have had this problem just a second ago. Solution for this problem was adding parameter "bind interfaces only = yes". Example configuration below:

interfaces = lo eth0 127.0.0.1 192.168.1.99
hosts allow = 127. 192.168.1.
bind interfaces only = yes # << <<< <<<< <<<<<<
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.