Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 2 cisco 3825 routers connected to two cisco 3560 switches. One is currently our main router with 3 /22 public addresses and the usual slew of rfc1918 address space routed around for internal usage. I would like to take a /24 and route it from our main router over to an identical router in a different room so that we can basically begin to isolate our colocation/dedicated customers from our home subscribers.

I'm not sure exactly how to do this so I can really use someone cisco gurus to jump in, if possible. I currently have the 2 routers connected directly via a /30, say for example here 192.168.159.97 on the main (core1) and 192.168.159.98 (core2) on the new one, on a seperate vlan between core1's gi0/1.4 and gi/0.0 on core2, the newer router. From here, I could choose to do something like this from core1:

ip route 192.168.200.0 255.255.255.0 192.168.159.98

How do I not prevent loops or otherwise hose myself? The default route on core1 one is a

ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.254.1

and I have the interface between the two setup up like this (with a switch providing vlan access between the 2 on vlan 9.

interface GigabitEthernet0/1.4
 description core1-to-core2
 encapsulation dot1Q 4
 ip address 192.168.159.97 255.255.255.252

I have a similar entry on core2,

ip classless
ip route 0.0.0.0 0.0.0.0 192.168.159.97

and

interface GigabitEthernet0/1.1
 encapsulation dot1Q 1 native
 ip address 192.168.200.1 255.255.255.0
 no snmp trap link-status
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.159.97

When I traceroute to 192.168.200.1, I get a loop between the 2 core1 and core 2 interfaces.

Edit: Sorry but I made a few typo's in the IP addresses ... s/169/168 and the interface ip address is a 1, not a 0.

share|improve this question
1  
There is no such thing as a Class C network any more. You've used the correct CIDR notation in your question, so I've removed it from the title. –  Mark Henderson Aug 23 '11 at 4:52

1 Answer 1

The answer from Shane is correct that there is a typo in your config but he only fixes part of the issue:

ip address 192.169.200.0 255.255.255.0

There is a simple typo here, s/169/168/, but the larger problem is your trying you use .0 (the network address) as an interface. While you can use the default network/broadcast address between newish network equipment (a change that was allowed so /31s could be used on point to point links), this is asking for trouble on a subnet with hosts on it. I would recommend something like

ip address 192.168.200.1 255.255.255.0
share|improve this answer
    
Heh, I missed the forest for the trees on that one - just fixing the typo fixes the loop, but not the actual connectivity. Thanks for the help :) –  Shane Madden Aug 23 '11 at 14:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.