Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
# my .bash_profile
function parse_git_branch {
    git branch --no-color 2> /dev/null | sed -e '/^[^*]/d' -e 's/* \(.*\)/(\1)/'


PS1="\w$YELLOW \$(parse_git_branch)$WHITE\$ "

for some reason the final $ and all of the text after that (what I actually type into the terminal) is now a bold white color.

I want it to be normal text-weight and white. How would I fix this?

share|improve this question
up vote 3 down vote accepted

My prompt uses \[\033[00m\] to go back to the terminal's default color setting. In your case, the 1; is what is activating "bright". If you change it to 0; you should get the "non-bright" white, no matter what your terminal's default color setting is (note that "non-bright" white is usually actually gray, and probably the default).

share|improve this answer

The text is bold and white because you asked it to be. Your WHITE code is asking for, well, white. What you probably want is something more like:


Then use that instead of WHITE.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.