Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an AWS EC2 instance. I was trying lo lock down (chroot) an SFTP account to its home directory using this guide. And I've managed to lock myself out of the server as I can no longer SSH in. I don't think telnet is enable as I tried

telnet <ip address>

and received the message

telnet: Unable to connect to remote host: Connection timed out

So, given this, does anyone have any idea how else I may be able to connect to the server to re-enable SSH?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

There doesn't look to be anything in that guide that would cause you to become locked out if you followed it correctly. Perhaps sshd isn't running and so won't accept new connections, have you tried rebooting the instance ? If that doesn't work then you're probably out of luck as there is no recovery console for EC2 instances.

share|improve this answer
    
I tried a reboot, but no joy. I think you're right about me not being able to get into it now. Thanks! –  hellsgate Aug 23 '11 at 10:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.