Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In order to connect to my job's VPN, I have been given by the network admin:

  • a username
  • a password
  • a PSK

I run Ubuntu at home. I know Fortigate's VPN should be a vanilla IPSec, so OpenSwan should do the trick. Still, I can't get it to work.

I have tried a program called "Forticlient" for Linux that I found through Google but it doesn't have the appropriate fields for the 3 items listed above.

Thanks!

share|improve this question

1 Answer 1

I haven't got Fortigate here to test. But could you please try enter the Server, User and Password:

enter image description here

click to Advanced Settings button and check on Use client certificate and browse to your file:

enter image description here

I also gave up trying with Openswan 2 years ago: both of NETKEY and KLIPS.

share|improve this answer
    
The PSK I have is not a certificate file, just an 18 character alphanumeric string. This is why I can't put it into the Forticlient. Any ideas? –  GomoX Aug 25 '11 at 13:34
    
The Forticlient program for Linux is intended to be used with an SSL VPN. I didn't have any luck getting IPSec (OpenSWAN) working. I talked my sysadmin into allowing the SSL VPN and the program appears to work fine. –  GomoX Nov 15 '11 at 18:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.