Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to access a file share on a Vista box from a RHEL 5.3 server.

The Vista box is part of a domain, but it has two NIC cards. One is on the 158.x.x.x network. The other card is on the 10.10.10.x network. RHEL box is on the 10.10.10.x network. The 10.10.10.x network is NOT part of the domain.

The IP of my Vista box is 10.10.10.50 while RHEL box is 10.10.10.60.

I can ping back and forth to both machines.

I executed this command from the RHEL box:

mount -t cifs -o username=username,password=password //hostname/transfer /mnt/transfer

/mnt/transfer does exist on the RHEL box.

hostname is defined in /etc/hosts

transfer does exist on the Vista box.

I verifed that the Windows Firewall Service is not running on the Vista box.

Username and Password are a valid password as that is the Domain password for my username.

But, I still get the mount error 110 from cifs.

Any clues?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You said the Vista box is part of a domain, therefore you must also pass the domain name or the mount command will attempt to authenticate to the Vista local machine's SAM database, instead of the domain's.

Try your command this way:

mount -t cifs -o username=username,password=password,domain=domain //hostname/transfer /mnt/transfer

Transfer may exist on the target Vista box as a folder name, but you should ensure that this is the name of the share as well. If you're on the Vista machine, open explorer and go to \127.0.0.1\, and ensure that the share is named transfer. You can change the name of the share in the Sharing tab for the folder.

You can also see if your credentials and everything are working by trying to list shares:

smbclient -L -U username -W domain host

This should prompt you for your password.

share|improve this answer
    
Verified by going to \\127.0.0.1 that transfer is the name of the share. I added the domain name, but I still get mount 110 error. –  Brian Aug 23 '11 at 16:05
    
See edit for smbclient command to test if the share is visible from the RHEL box –  Timothy Aug 23 '11 at 16:14
    
It says NT_STATUS_BAD_NETWORK_NAME (I used the IP address) –  Brian Aug 23 '11 at 16:19
    
Anything in /var/log/messages ? –  Timothy Aug 23 '11 at 16:23
    
It says: "CIFS VFC: Error connecting to socket. Aborting operation". –  Brian Aug 23 '11 at 17:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.