Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Running Win 2k8 R2 SP1 64 bit as a web server box with IIS 7/.NET 4.

Periodically, I completely lose access to the membership database in one of my sites (ASPNETDB) which causes a "Network Service cannot access Membership DB..." error on the site and makes the whole thing go down! Obviously not good.

Here's what I've already tried (with an Administrator account):

  • GUI tools to take ownership of that file, and of folder above it with propogation
  • Command line tools from an elevated command prompt: takeown, subinacl, icacl
  • Checked with Process Explorer and found no handles to the file

If I reboot the whole server the problem just goes away, but that is obviously not an efficient long term solution. Any other ideas on what/how to troubleshoot?

share|improve this question
    
And the file is there w/ the expected permissions after the reboot? You're not taking any steps after the reboot to resolve the issue-- it "just works"? –  Evan Anderson Aug 23 '11 at 19:31
    
Yes. There and functioning normally post reboot. –  just.another.programmer Aug 23 '11 at 19:31
    
Same problem here also .. had 4 pdf files that i suddenly couldn't access/change permissions on or take ownership of as Domain Admin. Wft is happening? This is on a Clean installed server W2008 R2 Sp1 Virtualized on Hyper-V. After i rebooted the server everything was ok again. This has happened on other customers servers also. Different AV programs, backup software etc. Only thing common are W2008 R2 and SP1 .. –  user106647 Jan 11 '12 at 10:36
    
I've occasionally seen similar problems on Windows 7 'Ultimate', 64 bit, with all current updates applied (15 Sep, 2013). I moved a folder, and was thereafter denied access to it, despite being able to access all the other folders at the same level. Rebooting would have been a major inconvenience, so I copied everything else to a new folder, recreated my errant files, and copied them (not moved) to the new destination. Then I could access them. It's absurd. My logon is an Administrator, but nothing I tried could restore my rights to my own files. –  user190113 Sep 16 '13 at 12:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.