Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have an issue resolving the alias record samresources.scholastic.com from our internal Windows 2008 DNS servers that are using hints - the result is non-existent domain (NXDOMAIN). It looks up fine when using a BIND server. I've also tried this from www.dnswatch.info - the results look the same as what I'm getting from Windows.

The record in question is a CNAME to samresources.education.scholastic.com (education added to the domain). The Windows server does resolve this A record correctly.

The name server for scholastic.com returns an NXDOMAIN result with an authority record of itself. And it is not one of the DNS servers for education.scholastic.com. Based on the info here: http://rfc-ref.org/RFC-TEXTS/2308/chapter2.html it seems it should not be returning itself as an authority record, not return an authority record at all, or it should return the authority record for education.scholastic.com or even return the A record from education.scholastic.com.

A really strange thing is that I can manage to get it to resolve if I run an nslookup 'set q=any' and then lookup samresources.scholastic.com. But then if I clear the forward cache and start nslookup over, it will fail again without the q=any.

Also, after clearning the cache, if I run nslookup set q=any scholastic.com - the result does not include the internet addresses of the ns1(primary) & ns2 nameservers, but it does return the internet addresses for the other nameservers.

I'm trying to figure out if this is an issue at scholastic.com or if it's something on my end (MS DNS).

Thank you

share|improve this question

2 Answers 2

up vote 1 down vote accepted

It's not you. DNSstuff is reporting the same thing you are, in addition to a few other problems.

share|improve this answer
    
I found www.dnsqueries.com and did a domain health check for scholastic.com. Problems reported that may be relevant: Your nameserver do not include A records when asked for your NS records, I have detected 6 stealth nameservers: pdns1.ultradns.net. pdns2.ultradns.net. pdns3.ultradns.org. pdns4.ultradns.org. pdns5.ultradns.info. pdns6.ultradns.co.uk. . These are listed in your nameservers but are missing in the parent zone nameservers. I don't have acess to DNSstuff but I have to agree with you. Thanks! –  Jay Aug 24 '11 at 14:32
    
Glad to help... –  joeqwerty Aug 25 '11 at 0:38

Everything appears to be working correctly when I look at the records. This is via a Windows DNS server. Maybe the hint is screwing up the lookup?

> samresources.scholastic.com
Server:  XXXXXXXX
Address:  192.168.2.100

Non-authoritative answer:
samresources.scholastic.com     canonical name = samresources.education.scholast
ic.com

samresources.education.scholastic.com   internet address = 63.251.75.101
> samresources.education.scholastic.com
Server:  XXXXXXXXXX
Address:  192.168.2.100

Non-authoritative answer:
samresources.education.scholastic.com   internet address = 63.251.75.101
>
share|improve this answer
    
The root hints appear to be working - all of their DNS server names resolve just fine. And FWIW, they have other cname records like teacher that do not involve their own DNS servers that do resolve. Thanks for responding! –  Jay Aug 23 '11 at 22:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.