Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a dedicated server running CentOS 5.3. I'm trying to update Plesk 9.5.2 to version 10.0.0 but update fails. I do it with yum:

yum update psa* --skip-broken -t

but it fails and I get the errors at the end:

Skip-broken could not solve problems
Error: plesk-mail-pc-driver conflicts with psa-qmail
Error: plesk-mail-pc-driver conflicts with psa-qmail-rblsmtpd
Error: plesk-mail-qc-driver conflicts with plesk-mail-pc-driver
Error: plesk-core conflicts with plesk-billing
Error: Missing Dependency: sw-engine = 2.0 is needed by package plesk-billing-6.0.4-20090625.11.noarch (installed)
Error: Missing Dependency: pp-sitebuilder >= 10.3.0 is needed by package psa-10.3.0-cos5.build1012110629.18.x86_64 (plesk)
Error: plesk-mail-pc-driver conflicts with plesk-mail-qc-driver

Is there a way that I could solve this?

share|improve this question

closed as off-topic by HopelessN00b Jan 14 '15 at 6:03

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

How do you want to solve this? Which of the conflicting packages do you want to eliminate? – mailq Aug 24 '11 at 12:33
I'm not even sure what those packages mean. – Caballero Aug 24 '11 at 13:14
Isn't this the question you have to ask yourself? And trying to force something you don't know with --skip-broken is not a good option, is it? Better question to yourself: Why updating when it's working? – mailq Aug 24 '11 at 13:18
I have to update because I'm switching servers and I need 100% compatibility (Plesk 10 is on the old server) – Caballero Aug 24 '11 at 13:22
This question appears to be off-topic because it is about working with a service provider's management interface, such as cPanel. – HopelessN00b Jan 14 '15 at 6:03
up vote 1 down vote accepted

Solved. Just used this autoinstaller and everything worked fine:

share|improve this answer

I had this same issue 2 days ago - I had to update from 9.2.2 via SSH to 9.5.4 then remove sitebuilder before it allowed me to update to 10.3.1 - works great now and has the updated sitebuilder on not that its used! The best way is probably what @Caballero said but this was useful for me and may help some one else out.

share|improve this answer

Try rebooting the server and update the Plesk using the autoinstaller or GUI Updater.

You can also check the migration with

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.