Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I created an own small server with Debian. Last night i updated it. It created an error while generating the initrd and it didn't boot.

Today i booted from another filesystem and did dpkg --configure -a with chroot. I also checked the filesystem.

Now everything should be ok.

But cron doesn't work:-( It is the same /etc/crontab-File but it doesn't work. I reinstalled cron and tried many things.

Is there a way to see cron's log? I only readed about rsyslog, but i have not installed rsyslog, because the server is based on a minimal system (Freeagent Dockstar).

Has someone an idea?

Best regards Silvio Keller


There is no file /var/log/syslog and dpkg -l|grep syslog gives me no output, so i think syslog is not installed. It is only a minimal system.

cron -l gives:

cron: can't lock /var/run/, otherpid may be 687: Resource temporarily unavailable

So i stopped cron with /etc/init.d/cron stop and executed cron -l again, this gives no output. At this moment i tried to start cron with /etc/init.d/cron start:

Starting periodic command scheduler: cron failed!

But there's no additional error info... But i see there's now in the background a proccess called cron -l which runs.

If i stop it /etc/init.d/cron start works:

Starting periodic command scheduler: cron.

I used the crontab-file /etc/crontab, this worked for me always. Till i updated my kernel and the initrd it doesn't.

The file's content is:

# m h dom mon dow user  command
17 *    * * *   root    cd / && run-parts --report /etc/cron.hourly
25 6    * * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )
47 6    * * 7   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.weekly )
52 6    1 * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.monthly )
00 5    * * *   root    dummy
23 45   * * 7   root    dummy

00 *    * * *   root    dummy
*/1 *   * * *   root    dummy
00 1    * * *   root    dummy
00 4    * * *   root    dummy
*/5 *   * * *   root    dummy
#00 */10 * * *  root    dummy

01 0    * * *   root    dummy
00 5    * * *   root    dummy
00 4    * * *   root    dummy

If i start crontab -e it creates a new file /tmp/crontab.vn87tv/crontab, which is unfortunaly on a tmpfs and which also doesn't work.

Thanks & Best regards

share|improve this question

marked as duplicate by Falcon Momot, Ward, MadHatter, Sven, Hauke Laging Jun 16 '13 at 16:53

This question was marked as an exact duplicate of an existing question.

The cron messages are stored in /var/log/syslog

What is the output of cron -l ?

To use crontab you have to edit the file using the crontab -e command. You can also run crons on Debian by placing a bash script in one of the directories:

share|improve this answer

I think the best way is if you fix the error with initrd at first place. Cron and syslog are consequences of that. However, if you prefer just to fix Cron you could try the following:

  • cp /etc/crontab /etc/crontab.orig - backup just in case;
  • crontab /etc/crontab - tell Cron to use /etc/crontab (man crontab is your friend).

After that, you would have to take care of the logging system. You could experiment also with /var/spool/cron/crontabs and create user crontabs, just to verify if the real issue is with /etc/crontab or the whole cron system. Another clue is if you boot back with the old kernel, just to test how things are.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.