Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Can anyone help me (I'm stuck) with configuring DNS server?

Description:

We have one Ubuntu 11.4-server machine and 3 Ubuntu 11.4-secktop.

Local IP addresses:

  • Ubuntu 11.4-server: 192.168.1.3
  • tolik (Ubuntu 11.4): 192.168.1.7
  • yura (Ubuntu 11.4): 192.168.1.77
  • artur (Ubuntu 11.4): 192.168.1.12

Goal:

Setup DNS server that any machine in our LAN can access http server on 192.168.1.3 via http://intell-sd.com

Atm we have bind 9 installed and this config:

/etc/bind/named.conf.local

zone "intell-sd.com" {
    type master;
    file "/etc/bind/zones/intell-sd.com.db";
};

zone "1.168.192.in-addr.arpa" {
    type master;
    file "/etc/bind/zones/rev.1.168.192.in-addr.arpa";
};

/etc/bind/named.conf.options

options {
    forwarders {
        213.130.16.20; #our provider DNS
    }
};

/etc/resolv.conf

search intell-sd.com.
nameserver 192.168.1.3

/etc/bind/zones/intell-sd.com.db

$TTL 3D
@ IN SOA ns.intell-sd.com. admin.intell-sd.com. (
    2007062001
    28800
    3600
    604800
    38400
);
intell-sd.com.  IN   NS        ns.intell-sd.com.
tolik           IN   A         192.168.1.7
artur           IN   A         192.168.1.77
yura            IN   A         192.168.1.12
WWW             IN   CNAME     artur
gw              IN   A         192.168.1.1
                     TXT       "Network Gateway"

/etc/bind/zones/rev.1.168.192.in-addr.arpa

$TTL 3D
@ IN SOA ns.intell-sd.com. admin.intell-sd.com. (
     2007062001
     28800
     604800
     604800
     86400
)
        IN      NS      ns.intell-sd.com.
1       IN      PTR     gw.intell-sd.com.
10      IN      PTR     tolik.intell-sd.com.
11      IN      PTR     yura.intell-sd.com.
12      IN      PTR     artur.intell-sd.com.

But nothing work (intell-sd.com return "aborted" status).

Debug:

BIND starts without any fails.

dig intell-sd.com (from 192.168.1.12):

global options: +cmd
Got answer:
->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 4434
flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

QUESTION SECTION:
intell-sd.com.          IN  A

Query time: 0 msec
SERVER: 192.168.1.3#53(192.168.1.3)
WHEN: Thu Aug 25 16:02:02 2011
MSG SIZE  rcvd: 31

nslookup gw

Server:     192.168.1.3
Address:    192.168.1.3#53

Non-authoritative answer:
*** Can't find gw: No answer
share|improve this question

2 Answers 2

You need a wildcard record for this.

Add the following to your intell-sd.com zone:

*      IN CNAME    WWW.intell-sd.com.

Also, you should change your WWW CNAME to point to the FQDN of artur:

WWW    IN CNAME    artur.intell-sd.com.
share|improve this answer
    
changed /etc/bind/zones/intell-sd.com.db but nothing happened –  Arthur Halma Aug 25 '11 at 14:38
    
Thanks a lot for your answer (+1)! But I reconfigured bind9 in some another way. –  Arthur Halma Aug 26 '11 at 5:18

There is no A record in the zone for intell-sd.com., which is your query in the dig output above. You could add it in the zone as follows to achieve your goal:

@           IN   A         192.168.1.3
share|improve this answer
    
add your line to /etc/bind/zones/intell-sd.com.db but nothing happened –  Arthur Halma Aug 25 '11 at 14:38
    
did you update the serial number in the zone and reload it? –  polynomial Aug 25 '11 at 18:29
    
Thanks a lot for your answer (+1)! But I reconfigured bind9 in some another way. –  Arthur Halma Aug 26 '11 at 5:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.