Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been running an ESXi 4.0 server for months with a couple of WinServer2003 and several Ubuntu Server 10.4 VMs. The performance has been impressive on 6GB i7 Asus P6T hardware.

Suddenly, a week ago, ssh logins to the Ubuntu VMs take 10 minutes when connecting over the LAN (over a WAN the connection (pipe) is broken long before that). When logging in to these VMs the password prompt arrives immediately, and failed passwords are responded to immediately.

But the moment I log in then the shell prompt appears and I hang for many minutes. Sometimes the connection hangs before the shell prompt appears and sometimes I can type in a command but the moment I hit return the machine hangs. 10 full minute later control returns and the VM is responsive.

NOTE: there are several Ubuntu VMs on the same host machine that are identical in all ways that I can tell. However, only one of the VMs displays this behavior. That is why I mention the ESXi host in passing - I don't think it has anything to do with the problem.

This behavior is never seen when I connect with the troubled-VM's console (through vSphere Client). From the console the Ubuntu VMs all respond beautifully.

I have seen: http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=1003496&sliceId=1&docTypeID=DT_KB_1_1&dialogID=229586372&stateId=1%200%20229588522 ...and since that relates to delays in seeing the password prompt that does not appear to be the solution here.

Any other suggestions very welcome - thank you.

share|improve this question
1  
Have you checked the logs? Run SSH with debugging options verbose? –  Bart Silverstrim Aug 25 '11 at 14:18
    
From the console try doing a TCPdump. Watch an incoming SSH session? Start up top and start an incoming connection. Perhaps you will see some weird DNS requests or something? Also, is it always exactly 10 minutes, or is that just the longest delay you have seen? –  Zoredache Aug 25 '11 at 18:34
6  
Try to disable reverse DNS by setting UseDNS no in sshd_config –  ceving Sep 5 '11 at 13:46
    
Because of the place where you report the problem, and the fact that it began 'suddenly', have you checked out any recent changes in your .bashrc or .bash_profile (or other shell init/rc script) in combination with ceving's suggestion above? –  Slartibartfast Sep 18 '11 at 6:54

2 Answers 2

switch off "use dns" in ssshd_config

share|improve this answer

It's frequently caused by GSSAPIAuthentication, set it to "no" in sshd_config and restart sshd.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.