Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a 64-bit CentOS 6.0 Linux computer with an Areca 1880i RAID card. The RAID card has its own ethernet port but it is right now not connected to anything. Instead of using that ethernet port for email notifications, I would like to send the email notifications from an ethernet port on the motherboard. I suppose that connecting the ethernet port on the RAID card directly to the internet is a bad idea security-wise because it runs its own firmware-based web server.

On this Areca web page:

http://www.areca.com.tw/support/s_linux/linux.htm

there is download link to the archttp software

http://www.areca.us/support/s_linux/http/x86_64/archttp64.zip

[root@server ~]# wget --quiet http://www.areca.us/support/s_linux/http/x86_64/archttp64.zip
[root@server ~]# unzip archttp64.zip 
Archive:  archttp64.zip
  inflating: archttp64       
[root@server ~]# chmod 755 archttp64 
[root@server ~]# ./archttp64  -h
Usage:

archttp32 [TCP Port#]
To Terminate the archttp: Press CTRL-C 
Command for reconfiguring the archttp: kill -sHUP <archttp's pid>
[root@server ~]# 

Here I notice that an empty configuration file was created when I ran ./archttp64 -h

[root@server ~]#  ls -l archttpsrv.conf 
-rw-r--r-- 1 root root 0 2011-08-25 15:56 archttpsrv.conf

I managed to start the web server software

[root@server ~]# ./archttp64 80
Copyright (c) 2004-2009 Areca, Inc. All Rights Reserved.
Areca HTTP proxy server, Version: V1.84, Arclib: 290, Date: Nov  2 2009

Starting HTTP Proxy Server...Please wait(MAX = 5 minutes)
Controller(s) list
-------------------------------------------------------
Controller[1](PCI) : Listen to port[80].
Cfg Assistant : Listen to port[81].
Binding IP: [0.0.0.0]
Note: IP[0.0.0.0] stands for any ip bound to this host.
-------------------------------------------------------

##############################
Press CTRL-C to exit program!!
##############################

I then accessed the web interface provided by archttp64 from my desktop computer by first creating a ssh tunnel

[user@desktop ~]$ ssh -N -L 8080:localhost:80 root@server.example.com

and then open the URL http://localhost:8080 in a Chromium web browser.

In the web interface I configured the fields for SMTP server and email addresses and chose Information notification as the event level, but no email was sent when I clicked Generate Test Event in the web interface.

How can I get the email notifications to work?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Although, email settings can be edited in the Controller web interface (here chosen to be TCP port 80), that doesn't seem to work. Instead you should edit the email settings in the Cfg Assistant web interface (here chosen to be TCP port 81). Create a ssh tunnel to your server

[user@desktop ~]$ ssh -N -L 8081:localhost:81 root@server.example.com

Note, that you then need to open the URL http://localhost:8081 in a Firefox web browser. The latest Chromium web browser (as of August 2011) will just show you a blank screen.

Instead of configuring the email settings through a web browser it is also possible to manually edit the file archttpsrv.conf and have it located in the current working directory from where you start archttp64. The file could look like this

[GENERAL]
BindingIp=127.0.0.1
HTTPPort=80
SMTPPort=25
ScanPci=YES
ScanRs232=NO
ScanInband=NO

[MAIL]
Server=130.237.98.104
Sender=arecaraid
SenderMail=arecaraid@example.com
Account=
Password=
MailToName1=arecaraid
MailToName2=
MailToName3=
MailToName4=
MailAddr1=arecaraid@example.com
MailAddr2=
MailAddr3=
MailAddr4=
EvtLevel=4
NotifyForNoEvent=YES

where Server is the SMTP server

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.