Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just set up Exim for sending email from a website using this guide:

All done with no problem.

When I open a test mail I sent to myself, in the "from" field, instead of showing only the website's address, it also shows my server's hostname.

I read the explanation from Gmail but can't figure out:

How could I hide it?

share|improve this question
It is not clear to me what you are talking about. Can you post the headers of an example message? – Zoredache Aug 25 '11 at 18:14

Have you followed the steps outlined by Google?

"Gmail checks whether emails are correctly authenticated. If your messages are sent by a bulk mailing vendor or by third-party affiliates, please publish an SPF record (#2) that includes the IPs of the vendor or affiliates which send your messages. Or, you may consider signing your messages with a DKIM (#3) signature that is associated with your domain."

Option 2, is probably the most straight forward which will also yield the most mileage (with other systems/site as well - besides Google)

" 2. SPF record: An SPF record is a list of IP addresses that are authorized to send mail for a particular domain. For more information on how to publish an SPF record, please visit"

share|improve this answer
Thanks. It looks to be the key. I am using a server hosting a few domains. It seems to be something to add to the DNS TXT records. Should I just add "v=spf1 a mx ~all" for each of my domain DNS? – Michael Aug 25 '11 at 18:57
That depends on your actual configuration. Are you actually sending or relaying from the same system(s) which will receive incoming emails for your domain? – user48838 Aug 25 '11 at 20:54

You are using SMTP right? Sending mail through a program using gmail servers should show any specified FROM address (easy to fake) but also the address of the account you used. Agreed, please post the "original" message with headers.

share|improve this answer
sure. message header is like this: From: via – Michael Aug 25 '11 at 18:51

The sender address (From: or SMTP envelope) you're using is not that of the Google Account with which you authenticated in the SMTP session.

Gmail's Submission service is for sending mail from a given account, not as a general purpose smarthost. You're claiming to be when sending via Gmail, so Gmail honors what you claim in the main display but shows more trace information to go with it.

If you want a general purpose smarthost for various pieces of software to use, Gmail is not the solution.

If you just want to be sending email from one account, authenticate as that account.

Gmail might (but I'm not sure) also let you by if you configure the sending address as another address for the account, under Mail Settings→Accounts and Import→Send mail as.

share|improve this answer

Gmail removes that 'sent-via' warning if you implement DKIM for your domain.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.