Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have this domain iarmar.com hosted in goDaddy and as my web server is with another host i am using host @ record to point it to my server. my webserver is powered by CentOS and Cpanel11. i tried creating godaddy from both goDaddy and cPanel although in both records get created but it won't work for example in goDaddy i went to.

Domain Manager > Forward Subdomains > Manage > Add Subdomain

and created the record there, below is the screenshot of the record i created in godaddy.

Godaddy Screenshot

this doesn't work, as i am unable to access the subdomain even after i created it. i tried through cPanel too but there too it won't work. is there something more record i should be changing like something in DNS manager of godaddy?

thanks.

share|improve this question

closed as too localized by Chris S, Shane Madden, Holocryptic, womble, Scott Pack Aug 27 '11 at 2:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
How long are you waiting to test the forward? sometimes DNS changes take a few minutes to propagate. In fact, that forward worked just fine for me. –  DKNUCKLES Aug 25 '11 at 20:46
    
are you sure, it worked fine for you, because it is still not working for me :( –  Ibrahim Azhar Armar Aug 25 '11 at 20:56

1 Answer 1

up vote 2 down vote accepted

When I check your DNS server the SOA record shows cache timeouts set for 2 hours... but when I check individual records they are set to 1 hour.

You would need to wait at least 1 hour after a change to be sure that records have been updated...

Sometimes, if you are running windows, you can try "ipconfig /flushdns" in a command window and then reload the url. DNS servers cache data too so you may need flush the cache on your local DNS server as well, if you have one. Sometimes that helps, other times you can't get to the main server and all you can do is wait for the timeout of the cache to check the new DNS records.

# dig iarmar.com soa

; <<>> DiG 9.4.2-P2 <<>> iarmar.com soa
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63713
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;iarmar.com. IN SOA

;; ANSWER SECTION:
iarmar.com. 3600 IN SOA ns27.domaincontrol.com. dns.jomax.net. 2011082500 28800 7200 604800 86400

;; AUTHORITY SECTION:
iarmar.com. 3563 IN NS ns27.domaincontrol.com.
iarmar.com. 3563 IN NS ns28.domaincontrol.com.

;; Query time: 79 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Aug 25 20:35:15 2011
;; MSG SIZE rcvd: 129

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.