Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an OS X 10.6. server that I have created 400 users accounts on. It is configured as an Open Directory Master - Home Accounts were created with LDAP and can I see the Home Accounts on the share - but cannot login with the created usernames. It is a fairly simple setup in that the users only need to connect via AFP for simple file transfers. I have other OS X servers that are Stand Alone, and do not rely on LDAP. Perhaps there is something basic I have missed in setting up the accounts?

share|improve this question
    
We need much more details here: How exactly did you configure your users, your shares and your clients? Did you create the users with Workgroup Manaager or with some other LDAP tool? What kind of error message do you get when you try to login? Are there any log messages? –  Sven Aug 25 '11 at 21:20
    
I used Passenger to mass import - then set home directories with WGM. I can login with the admin account created during install as well as the diradmin account. Not in front of client right now, but I believe the message was indicating the password was incorrect. –  mozzer Aug 25 '11 at 21:43

2 Answers 2

I don't know Passenger (what is it?), but it's likely you haven't created all necessary LDAP attributes and password server/Kerberos entries when importing your users.

Open Directory needs a set of Apple specific attributes to work correctly, so maybe try if everything works if you create a user from scratch in WGM.

share|improve this answer

Do you have service access control turned on? 10.6 server turns this on if you use the "Create Users and Groups" option in the initial setup. You can check and adjust it in Server Admin -> server name in sidebar -> Access in the toolbar -> Services tab below that -> AFP service in the list below that. You can either add users and/or groups to the access list, or just enable the service for all users & groups (that option is above the list on the right).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.