Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've searched high and low for an answer to this but I can not find it...which really surprises me...seems like this would be pretty standard.

I have IIS installed in my windows 7 machine and I can browse to things to no end at localhost. But when I try to pull up a page using the 192.168 address from my LAN, no dice.

I'm relatively new to this version of IIS so not sure if I'm missing something in there. I also checked in my firewall and enabled something that says "BranchCache Content Retrieval (HTTP-Out)...still no luck.

what am I missing here?


ok I added a new rule to my firewall to allow all incoming requests on port 80

I also created a new binding to my ip address in IIS.

still not working...any other ideas?

share|improve this question
    
well would it make it more on topic if the reason I need to do this is to test code I've written from my daughter's macbook :P just gotta make sure safari doesn't puke on my stuff. –  Christopher Johnson Aug 26 '11 at 2:14
    
This will likely get closed/off-topic, but it should be moved to SU. Unfortunately, we can't vote to migrate a question that was just migrated here from SO. SO should have just kicked it over to SU in the first place. –  EEAA Aug 26 '11 at 2:48
    
@Christopher - it was off-topic on SO because it was about setting up IIS properly on your network. It's off topic here because this is for home/personal use. –  EEAA Aug 26 '11 at 2:56
    
Additionally to what @ErikA stated (this site is for "system administrators and desktop support professionals" - this should not have been migrated here, sorry!), it would be helpful to provide details about what error you're getting when trying to load the site in a browser. –  Shane Madden Aug 26 '11 at 3:00
add comment

migrated from stackoverflow.com Aug 26 '11 at 2:14

This question came from our site for professional and enthusiast programmers.

closed as off topic by Shane Madden, womble, EEAA, mailq, Chris S Aug 26 '11 at 19:10

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

You need to create a new inbound rule in Windows Firewall that allows port 80.

share|improve this answer
add comment

Make sure

  • Your web-site bindings points to your IP-address and/or hostname you want it to be accessible on
  • Your firewall does not block incoming connections to port 80
  • The router does not block clients from connecting to each other (this is very unlikely)
  • Port 80 is not already in use
share|improve this answer
add comment

Your question is similar to this Sharing Localhost on Network in Windows 7

While I can't exactly find the page I got help from, you have to share your localhost folder first. Then you need to add port 8080 to be used to access this site. That should allow you to serve pages on the local network.

share|improve this answer
add comment