Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm facing a problem with the Apache/Tomcat/JDBC/Oracle communication configuration of an application.

Here are all the informations I have at my disposal about the problem :

  • A button on the web-app lauches a SQL/Oracle procedure that takes about 5 to 10 minutes to come to an end successfully.
  • The application is deployed on two distinct environnements. The Apache/Tomcat server configurations appear to be the same. The physical architecture, instead, is different (memory ressources, etc.)
  • On one environnement, when this procedure is lauched, it always aborts after around 5 minutes with an ERROR 503 : "Service Unavailable".

I know there is not a lot of details, but do you have any idea of the reason why such an error occur ?


share|improve this question
up vote 0 down vote accepted

The problem has been solved :

The Configuration file "http.conf" on the Apache server contains the following parameter :

# Timeout: The number of seconds before receives and sends time out.
Timeout 300 

This default parameter is set to 5 minutes. I extended this configuration to allow the procedure to terminate correctly.

share|improve this answer

Based off of the little information that you provided, I would guess that it is a very intensive procedure since it takes 5-10 minutes to return. I would also guess that the procedure is failing to execute to completion on the server with less memory which is why you are receving the "Service Unavailable" message. If you received a "Request Timed Out" message, then it would be a different case where the procedure could still be running, but didn't have enough time to finish before responding to your client.

Is the amount of memory on the second server significantly different than the amount of memory on the first server?

share|improve this answer
Thanks for the answer. Actually, the problem has been solved. I just updated the post with the solution. – Clem Sep 9 '11 at 8:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.