Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently joined a Windows 7 computer to a domain. There is one Computer Policy configured: the use of roaming profiles.

From the moment I restarted the client, I could stare for hours at the "Starting Windows" title with the nice colors of the windows logo. Now I have worked around this problem by specifying the roaming profile in the profile tab of the user. So I solved that problem.

What I would like to know however, is why this happens. I also have other servers (2008) that boot fast enough, XP clients that do, al clients in the same GPO structure. Only Windows 7 doesn't seem to like my Computer Policy.

Can anybody explain me the reasons why?

share|improve this question
    
Take a look at the Group Policy event log for info/clues as to what's happening. –  joeqwerty Aug 26 '11 at 12:40
    
I took a look on the client, there is a more-than-2-hour gap there. On the server, everything is normal, nothing special.. –  glenn Aug 26 '11 at 13:16
    
What do you mean "gap"? –  joeqwerty Aug 26 '11 at 13:22
    
oh, sorry, i mean there are no logs for 2 hours –  glenn Aug 26 '11 at 13:28
    
What are the "book end" entries in the log. The last one before the gap and the first one after the gap? –  joeqwerty Aug 26 '11 at 13:34
add comment

3 Answers

up vote 1 down vote accepted

Glenn,

Does the computer boot faster without Roaming Profiles enabled? Have you moved that computer to an OU where the roaming profiles GPO does not apply? If you haven't, please try that.

If you GPOs are set up correctly, you shouldn't see an increase in logon time when logging into Server 2008 because the Roaming Profiles GPO should not be applied to servers.

share|improve this answer
    
I have moved the computer to an other OU where there are no roaming profiles configured, this solver the problem! –  glenn Aug 26 '11 at 13:37
1  
That solved the problem? It sounds to me like you just obfuscated the problem by moving the computer object. The problem still exists, it just doesn't affect this particular computer anymore. If my car makes noise when I drive it, the fix isn't to stop driving it so that it doesn't make noise. The fix is to find the source of the noise... and fix it. –  joeqwerty Aug 26 '11 at 15:57
add comment

From your description it's a bit unclear if you're seeing the delay prior to logon or after logon. I would check your DNS settings on the problematic machine. I strongly suspect you have an invalid or external-to-the-forest DNS server specified in the machine's DNS configuration. The machine should have only DNS servers specified that are authoritative for the AD DNS name (typically DNS servers running on Domain Controller computers).

share|improve this answer
    
I have configured a DHCP server on the domain controller, I forgot about that :P –  glenn Aug 26 '11 at 12:37
add comment

Usually when this kind of thing happens, some Group Policy or another is trying to load/run, and can't for some reason. It may not even be the one you think it is, although roaming profiles is usually a high value suspect.

Your event logs should help point you in the right direction. Next, disable roaming profiles on that computer and see if that is indeed the troublesome GPO. Another step of troubleshooting would be to bridge the traffic and attach wireshark and start sniffing packets.

share|improve this answer
    
I shall check event logs and play around a little with the GPO's I have configured for the client, thanks! –  glenn Aug 26 '11 at 12:22
    
I took a look on the client, there is a more-than-2-hour gap there. On the server, everything is normal, nothing special.. –  glenn Aug 26 '11 at 13:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.