Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have problem with php5-gd. When I enter

sudo apt-get install php5-gd 

from terminal, I get this line:

Depends: php5-common (= 5.3.3-1ubuntu9.5) but 5.3.6-6~dotdeb.1 is to be installed. 

Can any one help me?

share|improve this question

2 Answers 2

You need to get rid of the dotdeb repo from your system... It is intended for debian, not for ubuntu, and while dotdob generally states that the packages "should work" in this particular instance, it is creating a conflict...

OR, if you absolutely must keep dotdeb, install php-common from the ubuntu repo specifically, and then install php5-gd

EDIT: Ok, just noticed how old this question is. Still, for anyone else in a similar situation, answer may be helpful, so not deleting it.

share|improve this answer
I would just say never use dotdeb on Ubuntu. It's generally unnecessary since Ubuntu has PPAs for virtually everything under the sun. – Michael Hampton Aug 1 '14 at 21:16
@MichaelHampton Yeah. IMHO there is no legitimate reason to use dotdeb on Ubuntu. – Joe Sniderman Aug 1 '14 at 21:30

Try these commands to update and upgrade all packages at first. Have you removed some update source in the mean time ?

apt-get update
apt-get upgrade
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.