Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i have problem with my opensuse 11.3 network. So, i've assigned ip 192.168.137.2 to it, and another computer (win7) with ip 192.168.137.1

On the opensuse, the gateway is the 192.168.137.1. and the ping result is

ping 192.168.137.1

PING 192.168.137.1 (192.168.137.1) 56(84) bytes of data.
64 bytes from 192.168.137.1: icmp_seq=1 ttl=128 time=2.53 ms
64 bytes from 192.168.137.1: icmp_seq=2 ttl=128 time=0.437 ms
^C
--- 192.168.137.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 0.437/1.487/2.537/1.050 ms

and the routing is

route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.137.0   0.0.0.0         255.255.255.0   U     0      0        0 eth0
10.1.1.0        0.0.0.0         255.255.255.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.137.1   0.0.0.0         UG    0      0        0 eth0

but, what the problem is,

traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 40 byte packets using UDP
 1  * * *
 2  * * *
 .
 .
 .
30  * * *

why does the traceroute not even reaching the gateway?? or may be, this is the networking rule i missed somehow.

share|improve this question

migrated from stackoverflow.com Aug 26 '11 at 19:20

This question came from our site for professional and enthusiast programmers.

    
How about traceroute -I 8.8.8.8? –  Shawn Chin Aug 26 '11 at 17:29

2 Answers 2

Maybe the UDP packets are being filtered. Try tcptraceroute.

share|improve this answer
    
sorry but, tcptraceroute: command not found any other options aside from installing it?? the linux doesn't have internet, yet. –  Lee Aug 26 '11 at 17:06
    
@Lee You're trying to do a traceroute without an internet connection? –  Shawn Chin Aug 26 '11 at 17:08
1  
try "traceroute -T" –  jman Aug 26 '11 at 17:09
    
@Shawn, he should still be able to trace within his local network. –  jman Aug 26 '11 at 17:10
2  
Does the Win7 machine have a built-in crossover or are you using a crossover cable? Also, where did those other routes come from? 10.1.1.0 and 169.254.0.0. Perhaps you should try deleting those and work on the internet connectivity first. Unless they are allocated in /etc/network/interfaces I think ifdown eth0 and then ifup eth0 should clear them. –  transistor1 Aug 26 '11 at 17:25

The reason probably is that the Windows 7 internal firewall filters some kinds of packets. Try to disable firewall in Win7 for a while. Use GUI Control Panel or start CLI window as an administrator and issue command

netsh firewall set opmode disable

Now repeat traceroute test. In case of positive response from your gateway 192.168.137.1 your next step must be to re-enable Win7 firewall

netsh firewall set opmode enable

and change its setting to allow the trace.

If problem persist with disabled W7 firewall you should check local firewall in OpenSUSE PC. Next command flushes all firewall rules and enables totally open communication till next reboot:

iptables -F *
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.