Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have created a virtual machine on a Hyper-V server, Dell PowerEdge with 24 Gb of RAM. I want to have four VMs with 2048 Mb of RAM each. Originally, I created this one (SV-YAMATO) with 512 Mb of RAM, now I want to extend it to 2048 through the Settings, but when I start it I get the following error message (see the screen shot). What can I do to fix this?

enter image description here

share|improve this question
1  
Does your c:\ drive have enough space to create the 2GB file needed for the memory? When you put the VM to sleep it swaps that back out to disk and it precreates the space for that on the drive. –  MikeAWood Aug 26 '11 at 19:52
    
The C:\ drive has only 227 MB free of 30 GB... However, the E:\ drive which contains all the .vhd files has 1.2 TB free. Isn't there a way to relocate this? –  JFB Aug 26 '11 at 20:03
2  
yeap... export the VM and recreate it on e:...when you create the VM, pay close attention. It actually asks you about where you want the files created and will default to the c: drive. In practice I tell the VMs to use e:\ by default which causes it to place all of the VM related files on that disk instead. (You'll see a few XML files that are related to this).. For what its worth, 227MB on the host drive on windows is pretty low, but thats a whole other question. –  MikeAWood Aug 26 '11 at 20:16
    
Ok... I found the option in Hyper-V Settings, there are two folders, Virtual Machines and Virtual Hard Disks (VHD). It works! –  JFB Aug 26 '11 at 20:17
    
For my own education, did it let you move them? I was under the impression (possibly wrong impression) that you couldn't move them. If you can, that is good to know.. –  MikeAWood Aug 26 '11 at 20:18
show 1 more comment

2 Answers

up vote 1 down vote accepted

You appear to be out of diskspace on the host. You'll have to reduce the memory used by the VM, since Hyper-V requires a "hibernation file" on the host for when the VM is suspended, as Mike noted.

share|improve this answer
    
There should be a way to set the path for the hibernation file? –  JFB Aug 26 '11 at 20:04
    
You need to relocate the Hyper-V service to your E:\ drive. Even if the VHDs are on the larger drive, the configuration is on your C:\ drive. –  Bigbio2002 Aug 26 '11 at 20:17
    
you can, but you can only set it when the VM is created. You can hack it by copying over the VHD to a new folder and creating a new VM for it, but i suggest exporting the VM out and recreating it and telling it to use e: instead. –  MikeAWood Aug 26 '11 at 20:17
add comment

I had a problem with Disk Quotas.

In short I did the following:

  1. disabled disk quotas
  2. started VM
  3. enabled quotas
  4. Look for user account "NT Virtual MACHINE**GUID**", then select "Do not limit disk usage"

Seems I found a "non standard configuration" to have file shares with disk quotas on the same volume as the VM .vhd's. Pre-existing VMs and their user account for disk quota's were OK, just a problem for new VM's.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.