Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Everything I find relating to this is the "ssh-exchange-identification:" error. This doesn't happen for me. I get two lines:

Connection to localhost closed by remote host.
Connection to localhost closed.

ssh -v localhost spits out:

OpenSSH_5.8p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to localhost [::1] port 22.
debug1: Connection established.
debug1: identity file /home/tim/.ssh/id_rsa type -1
debug1: identity file /home/tim/.ssh/id_rsa-cert type -1
debug1: identity file /home/tim/.ssh/id_dsa type -1
debug1: identity file /home/tim/.ssh/id_dsa-cert type -1
debug1: identity file /home/tim/.ssh/id_ecdsa type -1
debug1: identity file /home/tim/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.8
debug1: match: OpenSSH_5.8 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.8
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA 64:e3:27:90:ef:48:93:21:38:ea:9b:0e:0b:07:b0:2a
debug1: Host 'localhost' is known and matches the ECDSA host key.
debug1: Found key in /home/tim/.ssh/known_hosts:1
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /home/tim/.ssh/id_rsa
debug1: Trying private key: /home/tim/.ssh/id_dsa
debug1: Trying private key: /home/tim/.ssh/id_ecdsa
debug1: Next authentication method: keyboard-interactive
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: password
tim@localhost's password:
debug1: Authentication succeeded (password).
Authenticated to localhost ([::1]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: channel 0: free: client-session, nchannels 1
Connection to localhost closed by remote host.
Connection to localhost closed.
Transferred: sent 2008, received 1376 bytes, in 0.0 seconds
Bytes per second: sent 64774.0, received 44387.0
debug1: Exit status -1

I'm really at wit's end here because I couldn't get Windows' remote shell to even work. I'm so sick of using VNC just to get to a shell. Plus Windows' shell sucks because there is nothing like screen. Thanks

share|improve this question
add comment

3 Answers 3

Have you looked at PuTTY and/or Tera Term Pro as possible alternatives? They are both "cleaner" implementations as well.

share|improve this answer
    
I wasn't aware those were anything but clients. I use putty, but the problem here is a server, not a client. –  timramich Aug 27 '11 at 15:22
    
Being "cleaner implementations" as well as alternative options, they can assist in sorting out functionality vs. user error situations. –  user48838 Aug 27 '11 at 17:16
    
But the client wasn't my issue... –  timramich Aug 28 '11 at 4:03
    
Understood that it was purely a user issue. –  user48838 Aug 28 '11 at 6:12
add comment

Solved. Couldn't log in as my account, had to use sshd as the account.

share|improve this answer
    
Could you elaborate on using sshd as the account? I never manually set a passwd for it, and I'm afraid that if I do it something else will break. –  user100529 Nov 9 '11 at 22:41
add comment

First off, some friendly advice. For your own sanity, stop using VNC for connecting to Windows machines when you need a remote GUI. RDP will always be a better experience and comes with the base OS.

Second, there are numerous SSH Servers for Windows that are a lot less hassle than Cygwin with SSHD. Some are even free. There's a ServerFault thread about it here:

What is a good SSH server to use on Windows?

share|improve this answer
    
At the time I couldn't use RDP because it disables CUDA on nVidia cards. I've since given up on this because I got this cygwin ssh crap to work, but anything executed under it was painfully slow. –  timramich Jul 20 '12 at 1:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.