Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to deploy my Database to a web server but I can't get a connection to the SQL server installed in the web server using management studio 2008. I have already enabled TCP/IP protocol in sql server configuration manager. I also disabled the windows firewall but no result. I always get this error message :

TITLE: Connect to Server

Cannot connect to sql2008.metropol-beauty.com,1430.

ADDITIONAL INFORMATION:

A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: TCP Provider, error: 0 - The specified network name is no longer available.) (Microsoft SQL Server, Error: 64)

Any ideas?

share|improve this question
    
Is there a hardware firewall in between, if so, is it protocol aware (Watchguard Firewalls are the ones I have run into). If so, sometimes they like to detect a protocol and muck it up (esp. if it is an older version of the firmware, and the software you are using is newer). –  jgv999 Aug 28 '11 at 0:33
    
No there isn't such a thing. I could connect once with the same options but just once I don't know what's wrong. –  Milad Aug 28 '11 at 0:59
    
Can you try with an invalid login? Does it say "Login Failed"? –  jgv999 Aug 28 '11 at 1:17
add comment

2 Answers

up vote 2 down vote accepted

You need to ensure that the SQL port which is 1433 is open between the web server and e database server. You also need to ensure that the SQL sever is listening for remote connections. This can be cycled in the SQL Server Configurion Tool.

share|improve this answer
add comment

Is your server running as a named instance? I have seen something like this before and ended up installing the native client tools on the server and configuring my SQL server up in that. Seemed to resolve my issue, give it ago and see what happens.

http://www.microsoft.com/download/en/details.aspx?DisplayLang=en&id=8824

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.