Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem with xampp, when I try to start the Apache server it start and after few seconds it stop. I use both on my laptop, php and asp.net, so I have Visual Studio with IIS and xampp for the php projects. I tryed to check for the port :80 and nothing use this port except Skype (fixed on skype configurations) and Apache... so I don't understand where is the problem.

I'm sure there is a bug or a conflict with asp.net maybe, but it's hard for me to find the problem.

Hope you had this trouble before and can help me... thanks.

share|improve this question

migrated from stackoverflow.com Aug 28 '11 at 14:08

This question came from our site for professional and enthusiast programmers.

3 Answers 3

up vote 1 down vote accepted

I'm assuming IIS also uses port 80, as well as Apache on XAMPP and Skype. In Skype: Tools > Options > Advanced > Connection > Untick Use port 80 and 443 as alternatives for incoming connections

Then you have to change the port of either Apache or IIS. I'm not sure how to do this in IIS, but in Apache: Make sure Apache is off, then go to the Apache installation directory (since you're using XAMPP, this will most likely be C:\xampp\apache. In there find the conf folder, find httpd.conf and open it with Notepad or another editor. Find the line Listen 80 (around line 47), and change 80 to your desired port (often 8080, 8000 or 81 is used). Then find ServerName localhost:80 and again, replace 80 with your desired port (must be the same as the one used before) Save and start Apache.

Following above instructions should allow all three programs to connect without problems.

share|improve this answer
    
I do this, but it always try to start from port 80... –  Toro Aug 28 '11 at 14:07
    
Skype was the problem. No problem now using both IIS and Xampp. Thanks –  Toro Aug 31 '11 at 19:58
    
You're welcome. –  Hosh Sadiq Aug 31 '11 at 20:55

Look in Apache's error.log and Windows' system log. One of them will contain a detailed message about what went wrong. Double use of port 80 may be your problem already - only one program can be listening on a port.

share|improve this answer
    
How can I change one of these Listen ? –  Toro Aug 28 '11 at 13:58

Try to use another port other than 80. Sometimes is not working even unused.

share|improve this answer
    
If i go on /xampp/apache/conf/httpd.conf and I change the Listen from 80 to 8080 when I start apache it looks always to the port 80... –  Toro Aug 28 '11 at 13:57
    
If you are not forced to use xampp, I suggest to install wamp. –  musa Aug 28 '11 at 14:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.