Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a very strange problem. DHCP requests (to my router, going through my PowerConnect switch) take 35 - 40 seconds.

Here is my setup:

Router (pfSense) --> PowerConnect 2824 switch --> LAN

DHCP server is disabled on the PowerConnect 2824 but is enabled on my router. However, any requests on my LAN take 30 - 40 seconds to receive a DHCP response.

I've tried a different switch (Netgear Prosafe) and it works perfectly and I receive an instant DHCP response so I know the problem is not with my router.

Can anybody please help me out?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

It's probably got nothing to do with DHCP. It's probably spanning tree. The switch is simply unwilling to enable the port until it confirms that the port will not cause a disastrous loop in the network. The solution, assuming you know that the port will never, ever form a loop is to enable portfast (or 'fast link'). See this link:

http://www.mcbsys.com/techblog/2010/02/gigabit-switch-spanning-tree-causes-slow-logon/

share|improve this answer
1  
Dell calls this fast link. And I do believe they default to having STP enabled and fast link off on all ports. With some devices this can cause more than just a delay leaving the device unable to negotiate a network connection. This tends to only happen with embedded devices which are less forgiving of odd networking behaviors. –  3dinfluence Aug 28 '11 at 16:27
    
Thanks so much! That was the problem! I'm going to have to read up on spanning tree to understand what exactly it's doing... –  SofaKng Aug 28 '11 at 19:43
    
I never thought spanning tree would cause such a big lag. I currently have the problem that several workstations don´t install AD GPO policies.... because on bootup they don´t have a DHCP IP address yet. –  cljk May 29 '13 at 8:02

It's spanning tree. It's enabled by default on Dell switches. You can turn on portfast like this:

interface range ethernet e1-24
spanning-tree portfast

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.